# CVE-2026-61790: Weblate: Team-enforced 2FA is bypassed for global permissions


- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-x86c-ff69-cr2m

## What is CVE-2026-61790?

CVE-2026-61790 is a medium-severity vulnerability in WeblateOrg weblate, published on 26 Aug 2026. 

### Official description

Weblate is a web-based continuous localization platform used to manage software translations. In versions prior to 2026.7, a team can require its members to configure two-factor authentication before receiving the team's permissions, but this requirement is not enforced for site-wide global permissions. As a result, a user who belongs to a team that enforces 2FA and grants a global permission still receives that global permission even without 2FA configured, while the same requirement is correctly applied to project-, component-, and workspace-scoped permissions. Such a user can act on the granted global permission, including reaching the site management interface at /manage/. This issue is fixed in version 2026.7.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-61790?


## How do I fix CVE-2026-61790?

No fix has been published for CVE-2026-61790 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61790 being exploited?

There is no known exploitation of CVE-2026-61790 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61790 and fix it if it is affected.

What it is: CVE-2026-61790 is a medium-severity vulnerability in WeblateOrg weblate, published on 26 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-61790 in the wild and no public exploit code.

Affected product: WeblateOrg weblate. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61790/ (Markdown: https://insights.sbomify.com/CVE-2026-61790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61790
- OSV: https://osv.dev/vulnerability/CVE-2026-61790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61790/
Summaries are generated and may contain mistakes; the official description above is the record.
