# CVE-2026-61791: OCO-Server: Stored XSS through agent hostnames in command buttons


- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-9c2r-9j95-22pr

## What is CVE-2026-61791?

CVE-2026-61791 is a high-severity vulnerability in schorschii OCO-Server, published on 22 Oct 2026. 

### Official description

OCO-Server is a self-hosted endpoint management application for computer inventory, software deployment, and mobile device management. Prior to 1.2.1, `Html::commandButton()` in `lib/Html.class.php` embeds an action URL containing a stored computer hostname into a JavaScript string in an inline `onclick` handler, using `htmlspecialchars(ENT_QUOTES)` only for HTML escaping. Browsers decode the HTML entities before interpreting the handler as JavaScript, allowing a crafted hostname to escape the string and execute script in an administrator's authenticated session when an affected command button is activated. `frontend/views/computer-details.php` passes `$computer->hostname` to this helper using `Computer::DEFAULT_COMPUTER_COMMANDS` in `lib/Models/Computer.class.php`, whose VNC, RDP, SSH, and Ping entries use `new_tab=false` and the vulnerable `window.location` branch. A remote attacker who possesses the shared `agent-registration-key` can use the `oco.agent.hello` handler in `frontend/api-agent.php` to store an unchecked hostname when `agent-self-registration-enabled` is enabled; self-registration is disabled by default. The vulnerable default command buttons require no custom command configuration. The injected script can abuse the administrator's privileges, including permission to deploy software jobs to managed computers. This issue is fixed in version 1.2.1.

Weakness: CWE-83 (Improper Neutralization of Script in Attributes in a Web Page)

## Which versions are affected by CVE-2026-61791?


## How do I fix CVE-2026-61791?

No fix has been published for CVE-2026-61791 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61791 being exploited?

There is no known exploitation of CVE-2026-61791 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61791 and fix it if it is affected.

What it is: CVE-2026-61791 is a high-severity vulnerability in schorschii OCO-Server, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-61791 in the wild and no public exploit code.

Affected product: schorschii OCO-Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61791/ (Markdown: https://insights.sbomify.com/CVE-2026-61791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61791
- OSV: https://osv.dev/vulnerability/CVE-2026-61791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61791/
Summaries are generated and may contain mistakes; the official description above is the record.
