CVE-2026-61814 Jawn: Quadratic parsing effort in AsyncParser
A remote attacker can cause denial of service in applications using Jawn's AsyncParser by sending crafted JSON input that triggers quadratic CPU consumption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-61814?
CVE-2026-61814 is a high-severity denial of service vulnerability in org.typelevel jawn, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jawn is an open source JSON parser. Prior to 1.7.0, Jawn's AsyncParser can perform quadratic work when a single JSON token is delivered across many small chunks because each absorb call rescans the incomplete token from the start. A remote attacker who controls untrusted JSON input and its chunk sizes can exhaust CPU resources and cause denial of service in applications using AsyncParser. This issue is fixed in version 1.7.0.
Which versions are affected by CVE-2026-61814?
6 open source packages ship an affected version, including org.typelevel:jawn-parser_2.12, org.typelevel:jawn-parser_2.13 and org.typelevel:jawn-parser_3.
| Package | Affected | Fixed in |
|---|---|---|
org.typelevel:jawn-parser_2.12 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.12 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.13 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_2.13 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_3 Maven | All versions | 1.7.0 |
org.typelevel:jawn-parser_3 Maven | All versions | 1.7.0 |
Linux distribution packages (1)
jawn SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 0.14.1-150200.3.6.1 |
How do I fix CVE-2026-61814?
Upgrade org.typelevel:jawn-parser_2.12 to 1.7.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-61814 being exploited?
There is no known exploitation of CVE-2026-61814 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-61814, GHSA-w4cm-gvhj-cgw6, SUSE-SU-2026:4407-1, UBUNTU-CVE-2026-61814.