# CVE-2026-61814: Jawn: Quadratic parsing effort in AsyncParser

> A remote attacker can cause denial of service in applications using Jawn's AsyncParser by sending crafted JSON input that triggers quadratic CPU consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61814, GHSA-w4cm-gvhj-cgw6, SUSE-SU-2026:4407-1, UBUNTU-CVE-2026-61814

## What is CVE-2026-61814?

CVE-2026-61814 is a high-severity denial of service vulnerability in org.typelevel jawn, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jawn is an open source JSON parser. Prior to 1.7.0, Jawn's AsyncParser can perform quadratic work when a single JSON token is delivered across many small chunks because each absorb call rescans the incomplete token from the start. A remote attacker who controls untrusted JSON input and its chunk sizes can exhaust CPU resources and cause denial of service in applications using AsyncParser. This issue is fixed in version 1.7.0.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-61814?

6 open source packages ship an affected version, including org.typelevel:jawn-parser_2.12, org.typelevel:jawn-parser_2.13 and org.typelevel:jawn-parser_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.typelevel:jawn-parser_2.12` | Maven | All versions | 1.7.0 |
| `org.typelevel:jawn-parser_2.12` | Maven | All versions | 1.7.0 |
| `org.typelevel:jawn-parser_2.13` | Maven | All versions | 1.7.0 |
| `org.typelevel:jawn-parser_2.13` | Maven | All versions | 1.7.0 |
| `org.typelevel:jawn-parser_3` | Maven | All versions | 1.7.0 |
| `org.typelevel:jawn-parser_3` | Maven | All versions | 1.7.0 |
| `jawn` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 0.14.1-150200.3.6.1 |

## How do I fix CVE-2026-61814?

Upgrade org.typelevel:jawn-parser_2.12 to 1.7.0 or later.

## Is CVE-2026-61814 being exploited?

There is no known exploitation of CVE-2026-61814 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61814 and fix it if it is affected.

What it is: CVE-2026-61814 is a high-severity denial of service vulnerability in org.typelevel jawn, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61814 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.typelevel:jawn-parser_2.12 (Maven): affected all versions; fixed in 1.7.0
- org.typelevel:jawn-parser_2.12 (Maven): affected all versions; fixed in 1.7.0
- org.typelevel:jawn-parser_2.13 (Maven): affected all versions; fixed in 1.7.0
- org.typelevel:jawn-parser_2.13 (Maven): affected all versions; fixed in 1.7.0
- org.typelevel:jawn-parser_3 (Maven): affected all versions; fixed in 1.7.0
- org.typelevel:jawn-parser_3 (Maven): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61814/ (Markdown: https://insights.sbomify.com/CVE-2026-61814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61814
- OSV: https://osv.dev/vulnerability/CVE-2026-61814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61814/
Summaries are generated and may contain mistakes; the official description above is the record.
