# CVE-2026-61816: zbateson/mail-mime-parser has uncontrolled resource consumption (CPU/memory DoS) parsing untrusted MIME

> Attackers can cause denial of service via resource exhaustion by sending crafted MIME messages to applications using this PHP library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-f6v3-2qmr-vfjx

## What is CVE-2026-61816?

CVE-2026-61816 is a high-severity denial of service vulnerability in zbateson mail-mime-parser, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

zbateson/mail-mime-parser is a mail mime parser alternative to PHP's imap* functions and Pear libraries for reading messages in Internet Message Format RFC 822. Starting in version 2.0.0 and prior to version 3.0.6 and 4.0.2, an uncontrolled resource consumption / algorithmic complexity vulnerability (CWE-400) affects any application that parses untrusted email with this library. Three independent parsing paths are super-linear in cost, so a byte-size cap on the caller side does **not** bound the work done.  A crafted message under 2 MB can consume seconds of CPU or hundreds of megabytes to multiple gigabytes of memory (leading to an out-of-memory kill), enabling denial of service. The parse is lazy, but the cost is paid on the first `getAllParts()` or content read. This is fxed in 4.0.2 and 3.0.6. The fixes add configurable limits on multipart nesting depth and on header count / total header size (recording a parse error past the threshold rather than throwing), and change sibling append to O(n). Users should upgrade to one of these (or later) versions. Versions 2.x are also affected but are end-of-life and will not receive patches; users on those lines should upgrade to a fixed release. (Versions prior to 2.0 used a different parser and are not affected by all three paths.) These costs are super-linear, so an input byte-size cap alone does not bound them. Until upgrading, restrict exposure of the parser to untrusted input, and run parsing under a constrained memory_limit and execution time limit so a malicious message fails its own request rather than exhausting the host.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-61816?

4 open source packages ship an affected version, including zbateson/mail-mime-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zbateson/mail-mime-parser` | Packagist | From 2.0.0 | 3.0.6 |
| `zbateson/mail-mime-parser` | Packagist | From 2.0.0 | 3.0.6 |
| `zbateson/mail-mime-parser` | Packagist | From 4.0.0 | 4.0.2 |
| `zbateson/mail-mime-parser` | Packagist | From 4.0.0 | 4.0.2 |

## How do I fix CVE-2026-61816?

Upgrade zbateson/mail-mime-parser to a fixed version for your release line: 3.0.6 or 4.0.2.

## Is CVE-2026-61816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61816 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61816 and fix it if it is affected.

What it is: CVE-2026-61816 is a high-severity denial of service vulnerability in zbateson mail-mime-parser, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61816 exists.

Affected packages and fixed versions:
- zbateson/mail-mime-parser (Packagist): affected from 2.0.0; fixed in 3.0.6
- zbateson/mail-mime-parser (Packagist): affected from 2.0.0; fixed in 3.0.6
- zbateson/mail-mime-parser (Packagist): affected from 4.0.0; fixed in 4.0.2
- zbateson/mail-mime-parser (Packagist): affected from 4.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61816/ (Markdown: https://insights.sbomify.com/CVE-2026-61816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61816
- OSV: https://osv.dev/vulnerability/CVE-2026-61816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61816/
Summaries are generated and may contain mistakes; the official description above is the record.
