# CVE-2026-61817: pg_partman privilege escalation via SQL injection in several functions via time decoder

> Privileged users can inject SQL via time decoder settings in pg_partman, leading to superuser code execution and OS command execution.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61817, ECHO-d7c2-ca60-c9b7, GHSA-gmw2-52wc-258g, UBUNTU-CVE-2026-61817

## What is CVE-2026-61817?

CVE-2026-61817 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, run_maintenance(), show_partitions(), show_partition_info(), undo_partition(), and partition_data_time() interpolate the writable part_config.time_dncoder text value without identifier quoting into dynamic SQL. A role with the documented partman_user privileges can store SQL rather than a decoder function name. When an affected operation later uses the poisoned value, including pg_partman_bgw maintenance for a text- or UUID-keyed set, the SQL executes with the operation's privileges, which can be the default PostgreSQL superuser background-worker role. The persistent row can restore elevated access on later ticks, and successful exploitation can permit database-wide compromise and operating-system command execution as the PostgreSQL service account. This issue is fixed in version 5.5.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-61817?


## How do I fix CVE-2026-61817?

Upgrade to a fixed version.

## Is CVE-2026-61817 being exploited?

There is no known exploitation of CVE-2026-61817 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61817 and fix it if it is affected.

What it is: CVE-2026-61817 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61817 in the wild and no public exploit code.

Affected product: pgpartman pg_partman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61817/ (Markdown: https://insights.sbomify.com/CVE-2026-61817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61817
- OSV: https://osv.dev/vulnerability/CVE-2026-61817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61817/
Summaries are generated and may contain mistakes; the official description above is the record.
