# CVE-2026-61818: pg_partman SQL injection in undo partition time encoder

> An attacker with partman_user access can inject SQL via time_encoder in undo_partition, leading to code execution and privilege escalation when invoked by a privileged caller.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61818, ECHO-2f72-c3a8-d1f3, GHSA-fm3m-9fh7-mqfc, UBUNTU-CVE-2026-61818

## What is CVE-2026-61818?

CVE-2026-61818 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, undo_partition() reads part_config.time_encoder as unrestricted text and interpolates it without identifier quoting into a dynamically executed SELECT statement. A role with partman_user access can store SQL rather than a function name, and the SQL executes with the privileges of the caller that invokes undo_partition(). The function is not part of the default background-worker path, which limits the automatic superuser escalation described by the related create-partition vulnerability, but a privileged caller can still have its available confidentiality, integrity, and availability permissions abused. This issue is fixed in version 5.5.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-61818?


## How do I fix CVE-2026-61818?

Upgrade to a fixed version.

## Is CVE-2026-61818 being exploited?

There is no known exploitation of CVE-2026-61818 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61818 and fix it if it is affected.

What it is: CVE-2026-61818 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61818 in the wild and no public exploit code.

Affected product: pgpartman pg_partman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61818/ (Markdown: https://insights.sbomify.com/CVE-2026-61818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61818
- OSV: https://osv.dev/vulnerability/CVE-2026-61818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61818/
Summaries are generated and may contain mistakes; the official description above is the record.
