# CVE-2026-61819: pg_partman privilege escalation via SQL injection in when using pg_jobmon and encountering exception

> A SQL injection vulnerability in pg_partman allows privilege escalation to superuser and OS command execution when pg_jobmon is enabled.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61819, ECHO-7b96-3c92-04c6, GHSA-gv5h-j2cm-rhc3, UBUNTU-CVE-2026-61819

## What is CVE-2026-61819?

CVE-2026-61819 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, when pg_jobmon is installed and part_config.jobmon is true, exception handlers in multiple pg_partman functions place p_parent_table verbatim inside a SQL string literal used to call pg_jobmon.add_job(). A partman_user can create a parent-table name containing a single quote that terminates the literal and injects SQL when an affected exception path runs. If pg_partman_bgw reaches that path, the injected SQL executes with pg_partman_bgw.role privileges, which default to PostgreSQL superuser, permitting database-wide compromise and operating-system command execution as the PostgreSQL service account. The persistent part_config row can trigger the escalation again on later maintenance ticks. This issue is fixed in version 5.5.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-61819?


## How do I fix CVE-2026-61819?

Upgrade to a fixed version.

## Is CVE-2026-61819 being exploited?

There is no known exploitation of CVE-2026-61819 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61819 and fix it if it is affected.

What it is: CVE-2026-61819 is a high-severity SQL injection vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61819 in the wild and no public exploit code.

Affected product: pgpartman pg_partman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61819/ (Markdown: https://insights.sbomify.com/CVE-2026-61819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61819
- OSV: https://osv.dev/vulnerability/CVE-2026-61819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61819/
Summaries are generated and may contain mistakes; the official description above is the record.
