# CVE-2026-61821: pg_partman authorization bypass to move child tables between schemas during retention

> A low-privileged user can bypass authorization checks to move partitioned tables between schemas using the background worker's superuser privileges.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-61821, ECHO-e95d-6841-c84a, GHSA-pxp2-x8cf-rfhc, UBUNTU-CVE-2026-61821

## What is CVE-2026-61821?

CVE-2026-61821 is a high-severity missing authorization vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, drop_partition_id() and drop_partition_time() use part_config.retention_schema as the target for ALTER TABLE SET SCHEMA and accept any nonempty schema name. A role with partman_user access can select a target schema where the role lacks the normal CREATE privilege, and the background worker performs the relocation with pg_partman_bgw.role privileges, which default to PostgreSQL superuser, bypassing the authorization check that a normal ALTER TABLE SET SCHEMA operation would enforce. This permits unauthorized relocation of retained child tables between schemas. This issue is fixed in version 5.5.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-61821?


## How do I fix CVE-2026-61821?

Upgrade to a fixed version.

## Is CVE-2026-61821 being exploited?

There is no known exploitation of CVE-2026-61821 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61821 and fix it if it is affected.

What it is: CVE-2026-61821 is a high-severity missing authorization vulnerability in pgpartman pg_partman, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61821 in the wild and no public exploit code.

Affected product: pgpartman pg_partman. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61821/ (Markdown: https://insights.sbomify.com/CVE-2026-61821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61821
- OSV: https://osv.dev/vulnerability/CVE-2026-61821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61821/
Summaries are generated and may contain mistakes; the official description above is the record.
