{"answers":{"affected":"2 open source packages ship an affected version, including code16/sharp.","exploited":"There is no known exploitation of CVE-2026-61823 in the wild and no public exploit code.","fix":"Upgrade code16/sharp to 9.22.5 or later.","what":"CVE-2026-61823 is a high-severity cross-site scripting vulnerability in code16 sharp, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-61823 and fix it if it is affected.\n\nWhat it is: CVE-2026-61823 is a high-severity cross-site scripting vulnerability in code16 sharp, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-61823 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- code16/sharp (Packagist): affected all versions; fixed in 9.22.5\n- code16/sharp (Packagist): affected all versions; fixed in 9.22.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61823/ (Markdown: https://insights.sbomify.com/CVE-2026-61823/index.md)","id":"CVE-2026-61823","markdown":"https://insights.sbomify.com/CVE-2026-61823/index.md","name":"CVE-2026-61823","record":{"aliases":["GHSA-qxg3-46rw-79j8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel CMS framework","requires_auth":"low_privilege","summary":"Authenticated users can inject JavaScript via iframe srcdoc in the rich-text editor, leading to session hijacking and privilege escalation for other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"code16 Sharp is a Laravel-based framework for building content-management and administrative interfaces. Versions before 9.22.5 contain a stored cross-site scripting vulnerability in the rich-text editor because the HTML sanitizer permits the `srcdoc` attribute on iframe elements. Although markup inside `srcdoc` is HTML-encoded during sanitization, browsers decode attribute entities before interpreting the iframe document, allowing an authenticated user with permission to edit an Editor field to store executable JavaScript that runs when another user views the content. Successful exploitation can result in session hijacking, unauthorized actions, account takeover, privilege escalation, or disclosure of administrative data. Version 9.22.5 patches the vulnerability by removing `srcdoc` from the permitted iframe attributes. As a workaround, applications that cannot upgrade should manually sanitize all Editor field content and remove every iframe `srcdoc` attribute before storing or rendering it.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"code16 Sharp vulnerable to stored XSS via iframe srcdoc Attribute","id":"CVE-2026-61823","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Defuddle: XSS via unescaped attribute interpolation in site extractors","id":"CVE-2026-61824"},"packages":[{"ecosystem":"Packagist","fixed":["9.22.5"],"introduced":["0"],"last_affected":[],"package":"code16/sharp","purl":null,"source":"GHSA-qxg3-46rw-79j8"},{"ecosystem":"Packagist","fixed":["9.22.5"],"introduced":["0"],"last_affected":[],"package":"code16/sharp","purl":"pkg:composer/code16/sharp","source":"GHSA-qxg3-46rw-79j8"}],"prev":{"headline":"pg_partman disable maintenance for all partition sets","id":"CVE-2026-61822"},"products":["sharp"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["code16"]},"summary":"Authenticated users can inject JavaScript via iframe srcdoc in the rich-text editor, leading to session hijacking and privilege escalation for other users.","url":"https://insights.sbomify.com/CVE-2026-61823/"}