{"answers":{"affected":"2 open source packages ship an affected version, including defuddle.","exploited":"There is no known exploitation of CVE-2026-61824 in the wild and no public exploit code.","fix":"Upgrade defuddle to 0.19.1 or later.","what":"CVE-2026-61824 is a high-severity cross-site scripting vulnerability in kepano defuddle, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-61824 and fix it if it is affected.\n\nWhat it is: CVE-2026-61824 is a high-severity cross-site scripting vulnerability in kepano defuddle, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-61824 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- defuddle (npm): affected all versions; fixed in 0.19.1\n- defuddle (npm): affected all versions; fixed in 0.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-61824/ (Markdown: https://insights.sbomify.com/CVE-2026-61824/index.md)","id":"CVE-2026-61824","markdown":"https://insights.sbomify.com/CVE-2026-61824/index.md","name":"CVE-2026-61824","record":{"aliases":["GHSA-jg4p-g6xj-4qmf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"HTML cleaning library","requires_auth":"none","summary":"An attacker can inject malicious scripts into extracted HTML via unescaped attributes, leading to code execution when rendered by downstream applications.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Defuddle cleans up HTML pages. Prior to 0.19.1, site extractors interpolate page-derived image alt and src values, og:image values, and video descriptions into HTML strings without context-appropriate escaping, and buildExtractorResponse() returns this contentHtml without the main pipeline's DOM-based sanitization. The affected paths include src/extractors/x-article.ts, src/extractors/substack.ts, and src/extractors/youtube.ts. A malicious page or attacker-controlled content on a matching domain can inject event-handler attributes or javascript URLs that execute when a victim or downstream application renders the extracted HTML. This issue is fixed in version 0.19.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Defuddle: XSS via unescaped attribute interpolation in site extractors","id":"CVE-2026-61824","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"code16/sharp has a stored XSS via data-html-content Sanitizer Bypass","id":"CVE-2026-61825"},"packages":[{"ecosystem":"npm","fixed":["0.19.1"],"introduced":["0"],"last_affected":[],"package":"defuddle","purl":null,"source":"GHSA-jg4p-g6xj-4qmf"},{"ecosystem":"npm","fixed":["0.19.1"],"introduced":["0"],"last_affected":[],"package":"defuddle","purl":"pkg:npm/defuddle","source":"GHSA-jg4p-g6xj-4qmf"}],"prev":{"headline":"code16 Sharp vulnerable to stored XSS via iframe srcdoc Attribute","id":"CVE-2026-61823"},"products":["defuddle"],"published":"2026-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["kepano"]},"summary":"An attacker can inject malicious scripts into extracted HTML via unescaped attributes, leading to code execution when rendered by downstream applications.","url":"https://insights.sbomify.com/CVE-2026-61824/"}