# CVE-2026-61824: Defuddle: XSS via unescaped attribute interpolation in site extractors

> An attacker can inject malicious scripts into extracted HTML via unescaped attributes, leading to code execution when rendered by downstream applications.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-jg4p-g6xj-4qmf

## What is CVE-2026-61824?

CVE-2026-61824 is a high-severity cross-site scripting vulnerability in kepano defuddle, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Defuddle cleans up HTML pages. Prior to 0.19.1, site extractors interpolate page-derived image alt and src values, og:image values, and video descriptions into HTML strings without context-appropriate escaping, and buildExtractorResponse() returns this contentHtml without the main pipeline's DOM-based sanitization. The affected paths include src/extractors/x-article.ts, src/extractors/substack.ts, and src/extractors/youtube.ts. A malicious page or attacker-controlled content on a matching domain can inject event-handler attributes or javascript URLs that execute when a victim or downstream application renders the extracted HTML. This issue is fixed in version 0.19.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-61824?

2 open source packages ship an affected version, including defuddle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `defuddle` | npm | All versions | 0.19.1 |
| `defuddle` | npm | All versions | 0.19.1 |

## How do I fix CVE-2026-61824?

Upgrade defuddle to 0.19.1 or later.

## Is CVE-2026-61824 being exploited?

There is no known exploitation of CVE-2026-61824 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61824 and fix it if it is affected.

What it is: CVE-2026-61824 is a high-severity cross-site scripting vulnerability in kepano defuddle, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61824 in the wild and no public exploit code.

Affected packages and fixed versions:
- defuddle (npm): affected all versions; fixed in 0.19.1
- defuddle (npm): affected all versions; fixed in 0.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61824/ (Markdown: https://insights.sbomify.com/CVE-2026-61824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61824
- OSV: https://osv.dev/vulnerability/CVE-2026-61824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61824/
Summaries are generated and may contain mistakes; the official description above is the record.
