# CVE-2026-61825: code16/sharp has a stored XSS via data-html-content Sanitizer Bypass

> Attacker can inject malicious scripts via stored content in SharpEditorFormField, leading to XSS when viewed by other users.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-vj3q-vp3g-j9c8

## What is CVE-2026-61825?

CVE-2026-61825 is a high-severity cross-site scripting vulnerability in code16 sharp, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

code16 Sharp is a Laravel-based framework for building content-management and administrative interfaces. Versions before 9.22.5 contain a stored cross-site scripting vulnerability in `SharpEditorFormField`: attacker-controlled content bearing the `data-html-content` attribute can bypass HTML sanitization and preserve executable markup, which may execute when another user views the stored content. The vendor identifies version 9.22.5 as patched; applications that intentionally enable `SharpFormEditorField::RAW_HTML` must continue to sanitize editor content themselves. As a workaround, applications should sanitize all editor content before storing or rendering it, for example with Symfony HtmlSanitizer, and disable RAW_HTML functionality where it is not required.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-61825?

2 open source packages ship an affected version, including code16/sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code16/sharp` | Packagist | All versions | 9.22.5 |
| `code16/sharp` | Packagist | All versions | 9.22.5 |

## How do I fix CVE-2026-61825?

Upgrade code16/sharp to 9.22.5 or later.

## Is CVE-2026-61825 being exploited?

There is no known exploitation of CVE-2026-61825 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61825 and fix it if it is affected.

What it is: CVE-2026-61825 is a high-severity cross-site scripting vulnerability in code16 sharp, published on 24 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61825 in the wild and no public exploit code.

Affected packages and fixed versions:
- code16/sharp (Packagist): affected all versions; fixed in 9.22.5
- code16/sharp (Packagist): affected all versions; fixed in 9.22.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61825/ (Markdown: https://insights.sbomify.com/CVE-2026-61825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61825
- OSV: https://osv.dev/vulnerability/CVE-2026-61825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61825/
Summaries are generated and may contain mistakes; the official description above is the record.
