# CVE-2026-61834: scim-patch: Mutation of Inherited Built-in Method Objects

> Attackers can mutate global built-in objects via SCIM patch paths, potentially altering application logic in applications using scim-patch.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-2mhw-wcx5-v3xj

## What is CVE-2026-61834?

CVE-2026-61834 is a medium-severity vulnerability in thomaspoignant scim-patch, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

scim-patch is a library for applying SCIM patch operations. Prior to 0.9.2, navigate() reads inherited properties and assign() uses prototype-chain membership checks while resolving attacker-controlled SCIM PATCH paths. A path or one of the dotted value keys beginning with an inherited property such as toString can therefore traverse into a shared built-in function object and add attacker-controlled properties, causing process-global mutation that may affect application logic reading inherited-method properties. This issue is fixed in version 0.9.2.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-61834?

2 open source packages ship an affected version, including scim-patch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scim-patch` | npm | All versions | 0.9.2 |
| `scim-patch` | npm | All versions | 0.9.2 |

## How do I fix CVE-2026-61834?

Upgrade scim-patch to 0.9.2 or later.

## Is CVE-2026-61834 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61834 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61834 and fix it if it is affected.

What it is: CVE-2026-61834 is a medium-severity vulnerability in thomaspoignant scim-patch, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61834 exists.

Affected packages and fixed versions:
- scim-patch (npm): affected all versions; fixed in 0.9.2
- scim-patch (npm): affected all versions; fixed in 0.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61834/ (Markdown: https://insights.sbomify.com/CVE-2026-61834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61834
- OSV: https://osv.dev/vulnerability/CVE-2026-61834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61834/
Summaries are generated and may contain mistakes; the official description above is the record.
