# CVE-2026-61837: Missing authorization in rabbitmq-server

> Authenticated AMQP users can view full binding topology without management permissions, exposing routing details.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-rabbitmq-2026-61837, DEBIAN-CVE-2026-61837, GHSA-w9hf-476r-443x, UBUNTU-CVE-2026-61837

## What is CVE-2026-61837?

CVE-2026-61837 is a medium-severity missing authorization vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.3.3, 4.2.9, 4.1.14, and 4.0.23, AMQP 1.0 management GET /bindings exposes full binding topology to any authenticated AMQP user without resource/management permission checks. the AMQP 1.0 HTTP-over-AMQP management endpoint GET /bindings (the rabbitamqpmanagement handler) enumerates bindings between an arbitrary source exchange and destination queue/exchange in the caller's virtual host without performing any resource-level permission check. Unlike every sibling operation in the same module (which call checkresourceaccess / bindingchecks), the GET handler ignores the authenticated User and returns the binding list unchanged. As a result, any authenticated AMQP 1.0 client that can open a management link pair , including users with no management/monitoring/policymaker/administrator tag , can enumerate the complete binding topology (source exchanges, destination queues/exchanges, routing keys, and binding arguments) of the virtual host they can access. The equivalent HTTP management API (GET /api/bindings) Confidentiality impact: a non-management AMQP 1.0 user can enumerate the complete routing topology of any virtual host it can connect to , every (source exchange, destination queue/exchange, routing key, binding arguments) This issue is fixed in versions 4.3.3, 4.2.9, 4.1.14, and 4.0.23.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-61837?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 4.0.0 | 4.0.23, 4.1.14, 4.2.9, 4.3.3 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2026-61837?

Upgrade rabbitmq to a fixed version for your release line: 4.0.23, 4.1.14, 4.2.9 or 4.3.3.

## Is CVE-2026-61837 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61837 exists.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61837 and fix it if it is affected.

What it is: CVE-2026-61837 is a medium-severity missing authorization vulnerability in Broadcom Rabbitmq Server, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-61837 exists.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 4.0.0; fixed in 4.0.23, 4.1.14, 4.2.9, 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61837/ (Markdown: https://insights.sbomify.com/CVE-2026-61837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61837
- OSV: https://osv.dev/vulnerability/CVE-2026-61837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61837/
Summaries are generated and may contain mistakes; the official description above is the record.
