# CVE-2026-61842: Grav: Twig sandbox config exfiltration via grav.offsetGet + dump filter (CVE-2026-44738 bypass)

> A page-author can exfiltrate sensitive configuration secrets like API keys and credentials via Twig sandbox bypass in Grav.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026

## What is CVE-2026-61842?

CVE-2026-61842 is a medium-severity vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.2, the Grav Twig content sandbox permits grav.offsetGet('config') to return the raw configuration object and permits json_encode, print_r, yaml_encode, and string filters to serialize that object without passing through GravSecurityPolicy::checkMethodAllowed. A user with page-author permissions can render sandboxed content that exposes plugins.* configuration secrets, including SMTP credentials, API keys, and plugin database credentials. This issue is fixed in version 2.0.2.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-61842?


## How do I fix CVE-2026-61842?

Upgrade to a fixed version.

## Is CVE-2026-61842 being exploited?

There is no known exploitation of CVE-2026-61842 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61842 and fix it if it is affected.

What it is: CVE-2026-61842 is a medium-severity vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61842 in the wild and no public exploit code.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61842/ (Markdown: https://insights.sbomify.com/CVE-2026-61842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61842
- OSV: https://osv.dev/vulnerability/CVE-2026-61842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61842/
Summaries are generated and may contain mistakes; the official description above is the record.
