# CVE-2026-61855: Zammad: Invalid PGP Detached Signatures Reported as Good Signature on Inbound Mail

> Attackers can spoof PGP signatures in inbound emails, misleading support agents into trusting unverified content.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-r957-vp26-563q

## What is CVE-2026-61855?

CVE-2026-61855 is a medium-severity vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Zammad is a web based open source helpdesk/customer support system. In 7.0.3 and 7.1.1, under certain conditions, Zammad's verification of inbound PGP-signed email can mark a message as carrying a valid ("Good") PGP signature from a registered sender key, even though the displayed message content is not actually covered by that signature. As a result, the inbound article may be stored with a successful signature status that does not reflect the authenticity of the shown content. This can mislead agents who rely on the signature indicator when assessing the trustworthiness of incoming mail. This issue is fixed in version 7.1.2.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-61855?


## How do I fix CVE-2026-61855?

No fix has been published for CVE-2026-61855 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61855 being exploited?

There is no known exploitation of CVE-2026-61855 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61855 and fix it if it is affected.

What it is: CVE-2026-61855 is a medium-severity vulnerability in zammad, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-61855 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61855/ (Markdown: https://insights.sbomify.com/CVE-2026-61855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61855
- OSV: https://osv.dev/vulnerability/CVE-2026-61855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61855/
Summaries are generated and may contain mistakes; the official description above is the record.
