# CVE-2026-61899: Apache Tapestry: Possible classpath file download through URL manipulation

> Attackers can download classpath assets via crafted URLs in Apache Tapestry, exposing sensitive application files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-vx78-858g-p63x

## What is CVE-2026-61899?

CVE-2026-61899 is a high-severity path traversal vulnerability in Apache Tapestry, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in tapestry-core in Apache Tapestry 5.5.0+ on all platforms allows attackers to download clsspath assets via specially crafted URLs.
Users are recommended to upgrade to version 5.9.1, which fixes this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-61899?

It affects 1 product.


Products: Apache Tapestry.

## How do I fix CVE-2026-61899?

No fix has been published for CVE-2026-61899 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-61899 being exploited?

There is no known exploitation of CVE-2026-61899 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tapestry

- [CVE-2022-46366](https://insights.sbomify.com/CVE-2022-46366/): Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input (critical 9.8)
- [CVE-2021-27850](https://insights.sbomify.com/CVE-2021-27850/): Bypass of the fix for CVE-2019-0195 (critical 9.8)
- [CVE-2020-17531](https://insights.sbomify.com/CVE-2020-17531/): Deserialization flaw in EOL Tapestry 4. (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-61899 and fix it if it is affected.

What it is: CVE-2026-61899 is a high-severity path traversal vulnerability in Apache Tapestry, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-61899 in the wild and no public exploit code.

Affected product: Apache Tapestry. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-61899/ (Markdown: https://insights.sbomify.com/CVE-2026-61899/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-61899
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-61899
- OSV: https://osv.dev/vulnerability/CVE-2026-61899

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-61899/
Summaries are generated and may contain mistakes; the official description above is the record.
