{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-6210 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-6210 is a high-severity memory corruption vulnerability in Qt, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6210 and fix it if it is affected.\n\nWhat it is: CVE-2026-6210 is a high-severity memory corruption vulnerability in Qt, published on 6 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6210 in the wild and no public exploit code.\n\nAffected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6210/ (Markdown: https://insights.sbomify.com/CVE-2026-6210/index.md)","id":"CVE-2026-6210","markdown":"https://insights.sbomify.com/CVE-2026-6210/index.md","name":"CVE-2026-6210","record":{"aliases":["DEBIAN-CVE-2026-6210","GHSA-mh4x-qpf6-hr3q","UBUNTU-CVE-2026-6210","openSUSE-SU-2026:10742-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt SVG library","requires_auth":"none","summary":"An attacker can crash applications using Qt SVG by providing a crafted SVG image that triggers a type confusion and heap overflow.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TQtC","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A type confusion vulnerability in Qt SVG allows an attacker to cause an application crash via a crafted SVG image.\n\nWhen processing SVG marker references, the renderer retrieves a node by its id attribute and casts it to QSvgMarker* without verifying the node type. A non-marker element (such as a \u003cline\u003e element) that references itself as a marker triggers an out-of-bounds heap read due to the object size difference between QSvgLine and QSvgMarker,\n followed by an endless recursion that bypasses the marker recursion \nguard through incorrect virtual dispatch. The result is an application \ncrash (denial of service).\n\nThis issue affects Qt SVG: \nfrom 6.7.0 before 6.8.8, from 6.9.0 before 6.11.1.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Type confusion and heap-buffer-overflow in Qt SVG marker handling causing application crash","id":"CVE-2026-6210","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Arbitrary File Upload in Global IT's WEOLL","id":"CVE-2026-6211"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.11.0-2.1"],"introduced":["0"],"last_affected":[],"package":"qt6-svg","purl":"pkg:rpm/opensuse/qt6-svg\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10742-1"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2026-6209"},"products":["Qt"],"published":"2026-05-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["Qt"]},"summary":"An attacker can crash applications using Qt SVG by providing a crafted SVG image that triggers a type confusion and heap overflow.","url":"https://insights.sbomify.com/CVE-2026-6210/"}