# CVE-2026-6216: DbGate SVG Icon String FontIcon.svelte cross site scripting


- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-j8j5-7r4h-vj2g

## What is CVE-2026-6216?

CVE-2026-6216 is a medium-severity vulnerability in DbGate, published on 13 Apr 2026. 

### Official description

A security vulnerability has been detected in DbGate up to 7.1.4. This affects an unknown function of the file packages/web/src/icons/FontIcon.svelte of the component SVG Icon String Handler. Such manipulation of the argument applicationIcon leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 7.1.5 mitigates this issue. It is advisable to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6216?

2 open source packages ship an affected version, including dbgate-web.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbgate-web` | npm | All versions | 7.1.5 |
| `dbgate-web` | npm | All versions | 7.1.5 |

## How do I fix CVE-2026-6216?

Upgrade dbgate-web to 7.1.5 or later.

## Is CVE-2026-6216 being exploited?

There is no known exploitation of CVE-2026-6216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6216 and fix it if it is affected.

What it is: CVE-2026-6216 is a medium-severity vulnerability in DbGate, published on 13 Apr 2026. 
Exploitation: There is no known exploitation of CVE-2026-6216 in the wild and no public exploit code.

Affected packages and fixed versions:
- dbgate-web (npm): affected all versions; fixed in 7.1.5
- dbgate-web (npm): affected all versions; fixed in 7.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6216/ (Markdown: https://insights.sbomify.com/CVE-2026-6216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6216
- OSV: https://osv.dev/vulnerability/CVE-2026-6216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6216/
Summaries are generated and may contain mistakes; the official description above is the record.
