CVE-2026-62183 Apache Syncope: User self-service privilege escalation
Attackers can escalate privileges to administrator via self-service API if specific workflow adapters are configured without admin approval.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-62183?
CVE-2026-62183 is a critical vulnerability in Apache Syncope, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Privilege Management vulnerability in Apache Syncope.
When:
* the all-Java user workflow adapter is configured, or * the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests
the following scenario could happen. A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1.
Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.
Weakness: CWE-269
Which versions are affected by CVE-2026-62183?
It affects 1 product.
Products include Apache Syncope.
How do I fix CVE-2026-62183?
No fix has been published for CVE-2026-62183 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-62183 being exploited?
There is no known exploitation of CVE-2026-62183 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Syncope
- CVE-2026-53405 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask
- CVE-2026-53421 Apache Syncope: Remote Code Execution via Scripted Connector
- CVE-2026-57308 Apache Syncope: SQL injection vulnerability in Audit Events search
- CVE-2026-63071 Apache Syncope: RCE via Groovy Sandbox bypass
- CVE-2020-1959 Expression Language Injection in Apache Syncope
Sources
Also known as GHSA-p386-8623-243g.