{"answers":{"affected":"2 open source packages ship an affected version, including @openclaw/feishu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-62187 in the wild and no public exploit code.","fix":"Upgrade @openclaw/feishu to 2026.6.9 or later.","what":"CVE-2026-62187 is a high-severity authentication bypass vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-62187 and fix it if it is affected.\n\nWhat it is: CVE-2026-62187 is a high-severity authentication bypass vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-62187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9\n- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62187/ (Markdown: https://insights.sbomify.com/CVE-2026-62187/index.md)","id":"CVE-2026-62187","markdown":"https://insights.sbomify.com/CVE-2026-62187/index.md","name":"CVE-2026-62187","record":{"aliases":["GHSA-2q7j-2vhx-56g8","GHSA-mm88-h44m-w2gp","MINI-jpx8-26m3-cv37"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Feishu integration library","requires_auth":"low_privilege","summary":"An authorization bypass in OpenClaw Feishu tools allows lower-trust callers to perform unauthorized actions if specific configurations are present.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"openclaw\\/feishu","vendor":"openclaw"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OpenClaw Feishu tools (npm package @openclaw/feishu) in versions \u003c= 2026.6.6 could ignore per-account disablement. A lower-trust caller or a configured input path could perform actions that should have required a stronger authorization or policy check, resulting in unauthorized operations. The issue is fixed in version 2026.6.9. Impact depends on the operator's configuration and whether lower-trust input can reach the affected feature.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"OpenClaw \u003c 2026.6.9 Feishu tools Authorization Bypass","id":"CVE-2026-62187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OpenClaw \u003c 2026.6.9 Feishu Authorization Bypass","id":"CVE-2026-62188"},"packages":[{"ecosystem":"npm","fixed":["2026.6.9"],"introduced":["0"],"last_affected":[],"package":"@openclaw/feishu","purl":null,"source":"GHSA-2q7j-2vhx-56g8"},{"ecosystem":"npm","fixed":["2026.6.9"],"introduced":["0"],"last_affected":[],"package":"@openclaw/feishu","purl":"pkg:npm/%40openclaw/feishu","source":"GHSA-2q7j-2vhx-56g8"}],"prev":{"headline":"OpenClaw \u003c 2026.6.8 Authorization Bypass via HTTP Model Override","id":"CVE-2026-62186"},"products":["feishu"],"published":"2026-07-13","related":[{"cvss_score":8.6,"headline":"OpenClaw \u003c 2026.6.9 Feishu Authorization Bypass","id":"CVE-2026-62188","kev_date_added":null,"published":"2026-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["openclaw"]},"summary":"An authorization bypass in OpenClaw Feishu tools allows lower-trust callers to perform unauthorized actions if specific configurations are present.","url":"https://insights.sbomify.com/CVE-2026-62187/"}