# CVE-2026-62187: OpenClaw < 2026.6.9 Feishu tools Authorization Bypass

> An authorization bypass in OpenClaw Feishu tools allows lower-trust callers to perform unauthorized actions if specific configurations are present.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-2q7j-2vhx-56g8, GHSA-mm88-h44m-w2gp, MINI-jpx8-26m3-cv37

## What is CVE-2026-62187?

CVE-2026-62187 is a high-severity authentication bypass vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw Feishu tools (npm package @openclaw/feishu) in versions <= 2026.6.6 could ignore per-account disablement. A lower-trust caller or a configured input path could perform actions that should have required a stronger authorization or policy check, resulting in unauthorized operations. The issue is fixed in version 2026.6.9. Impact depends on the operator's configuration and whether lower-trust input can reach the affected feature.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62187?

2 open source packages ship an affected version, including @openclaw/feishu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openclaw/feishu` | npm | All versions | 2026.6.9 |
| `@openclaw/feishu` | npm | All versions | 2026.6.9 |

Products: Openclaw Openclaw\/Feishu.

## How do I fix CVE-2026-62187?

Upgrade @openclaw/feishu to 2026.6.9 or later.

## Is CVE-2026-62187 being exploited?

There is no known exploitation of CVE-2026-62187 in the wild and no public exploit code.

## Other vulnerabilities in openclaw feishu

- [CVE-2026-62188](https://insights.sbomify.com/CVE-2026-62188/): OpenClaw < 2026.6.9 Feishu Authorization Bypass (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62187 and fix it if it is affected.

What it is: CVE-2026-62187 is a high-severity authentication bypass vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62187 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9
- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62187/ (Markdown: https://insights.sbomify.com/CVE-2026-62187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62187
- OSV: https://osv.dev/vulnerability/CVE-2026-62187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62187/
Summaries are generated and may contain mistakes; the official description above is the record.
