# CVE-2026-62188: OpenClaw < 2026.6.9 Feishu Authorization Bypass

> Attackers can bypass Feishu permission checks to perform unauthorized actions if the feature is enabled, requiring an upgrade to OpenClaw Feishu library.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-gqfx-xr3c-xq42, GHSA-w8wf-3qvj-6xqf, MINI-832g-qg67-ch67

## What is CVE-2026-62188?

CVE-2026-62188 is a high-severity missing authorization vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw @openclaw/feishu versions 2026.6.6 and earlier contain an incorrect authorization vulnerability in which the Feishu permission tools could ignore per-account disablement settings. When the affected feature is enabled and reachable, a lower-trust caller or configured input path could perform actions that should have required a stronger authorization or policy check. The issue is fixed in version 2026.6.9.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62188?

2 open source packages ship an affected version, including @openclaw/feishu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openclaw/feishu` | npm | All versions | 2026.6.9 |
| `@openclaw/feishu` | npm | All versions | 2026.6.9 |

Products: Openclaw Openclaw\/Feishu.

## How do I fix CVE-2026-62188?

Upgrade @openclaw/feishu to 2026.6.9 or later.

## Is CVE-2026-62188 being exploited?

There is no known exploitation of CVE-2026-62188 in the wild and no public exploit code.

## Other vulnerabilities in openclaw feishu

- [CVE-2026-62187](https://insights.sbomify.com/CVE-2026-62187/): OpenClaw < 2026.6.9 Feishu tools Authorization Bypass (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62188 and fix it if it is affected.

What it is: CVE-2026-62188 is a high-severity missing authorization vulnerability in openclaw feishu, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62188 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9
- @openclaw/feishu (npm): affected all versions; fixed in 2026.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62188/ (Markdown: https://insights.sbomify.com/CVE-2026-62188/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62188
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62188
- OSV: https://osv.dev/vulnerability/CVE-2026-62188

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62188/
Summaries are generated and may contain mistakes; the official description above is the record.
