# CVE-2026-62204: SiYuan before v3.7.4 Plugin Overwrite via Bazaar Install

> Attackers can overwrite trusted plugins via mismatched package names in SiYuan, enabling persistent code execution.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-rpx2-p6hp-x5gj

## What is CVE-2026-62204?

CVE-2026-62204 is a medium-severity missing authorization vulnerability in siyuan-note siyuan, published on 22 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

SiYuan versions before v3.7.4 fail to validate that packageName matches the downloaded package content in bazaar install endpoints. Attackers with same-origin access can overwrite existing trusted plugins by supplying mismatched packageName and repoURL parameters, achieving persistence across application restarts.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-62204?

2 open source packages ship an affected version, including github.com/siyuan-note/siyuan/kernel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260808010544-26ccb40d390e |
| `github.com/siyuan-note/siyuan/kernel` | Go | All versions | 0.0.0-20260808010544-26ccb40d390e |

## How do I fix CVE-2026-62204?

Upgrade github.com/siyuan-note/siyuan/kernel to 0.0.0-20260808010544-26ccb40d390e or later.

## Is CVE-2026-62204 being exploited?

There is no known exploitation of CVE-2026-62204 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62204 and fix it if it is affected.

What it is: CVE-2026-62204 is a medium-severity missing authorization vulnerability in siyuan-note siyuan, published on 22 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-62204 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260808010544-26ccb40d390e
- github.com/siyuan-note/siyuan/kernel (Go): affected all versions; fixed in 0.0.0-20260808010544-26ccb40d390e

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62204/ (Markdown: https://insights.sbomify.com/CVE-2026-62204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62204
- OSV: https://osv.dev/vulnerability/CVE-2026-62204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62204/
Summaries are generated and may contain mistakes; the official description above is the record.
