# CVE-2026-62231: Grav < 1.0.6 API Key Scope Bypass via ApiKeyAuthenticator

> Attackers with limited-scope API keys can perform unauthorized write, delete, or administrative actions due to missing scope enforcement in the Grav API plugin.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-q7w3-h9x7-95x7

## What is CVE-2026-62231?

CVE-2026-62231 is a high-severity missing authorization vulnerability in getgrav grav, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Grav API plugin (getgrav/grav-plugin-api) before 1.0.6 contains an authorization bypass: API keys can be created with a restricted scopes array, but the ApiKeyAuthenticator class never reads or enforces these scopes. It loads and returns the owning user's full account object, so a key created with limited scopes (e.g. read-only) can perform any write, delete, or administrative operation the owning user is authorized for. Fixed in 1.0.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62231?


## How do I fix CVE-2026-62231?

No fix has been published for CVE-2026-62231 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62231 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62231 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62231 and fix it if it is affected.

What it is: CVE-2026-62231 is a high-severity missing authorization vulnerability in getgrav grav, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62231 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62231/ (Markdown: https://insights.sbomify.com/CVE-2026-62231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62231
- OSV: https://osv.dev/vulnerability/CVE-2026-62231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62231/
Summaries are generated and may contain mistakes; the official description above is the record.
