# CVE-2026-62238: OpenRemote < 1.26.0 SQL Injection via Crosstab Export

> Authenticated attackers can inject SQL via asset names in the crosstab export endpoint to exfiltrate database data from OpenRemote.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-cgfv-jrfp-2r7v, GHSA-rw7h-h988-gfff

## What is CVE-2026-62238?

CVE-2026-62238 is a high-severity SQL injection vulnerability in openremote, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote before 1.26.0 contain an authenticated SQL injection vulnerability in the datapoint crosstab export endpoint that constructs PostgreSQL queries by concatenating asset display names into raw SQL. An authenticated attacker with asset creation or rename permissions can inject SQL through the asset name parameter and receive query results in the exported CSV response, enabling database data exfiltration.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-62238?

2 open source packages ship an affected version, including io.openremote:openremote-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.openremote:openremote-manager` | Maven | All versions | 1.26.0 |
| `io.openremote:openremote-manager` | Maven | All versions | 1.26.0 |

Products: Openremote Openremote.

## How do I fix CVE-2026-62238?

Upgrade io.openremote:openremote-manager to 1.26.0 or later.

## Is CVE-2026-62238 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62238 exists.

## Other vulnerabilities in openremote

- [CVE-2026-39842](https://insights.sbomify.com/CVE-2026-39842/): OpenRemote is Vulnerable to Expression Injection (critical 10.0)
- [CVE-2022-31860](https://insights.sbomify.com/CVE-2022-31860/): Code injection in n/a (critical 9.8)
- [CVE-2026-40882](https://insights.sbomify.com/CVE-2026-40882/): OpenRemote has XXE in Velbus Asset Import (high 7.6)
- [CVE-2026-41166](https://insights.sbomify.com/CVE-2026-41166/): OpenRemote has Improper Access Control via updateUserRealmRoles function (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62238 and fix it if it is affected.

What it is: CVE-2026-62238 is a high-severity SQL injection vulnerability in openremote, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62238 exists.

Affected packages and fixed versions:
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.26.0
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62238/ (Markdown: https://insights.sbomify.com/CVE-2026-62238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62238
- OSV: https://osv.dev/vulnerability/CVE-2026-62238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62238/
Summaries are generated and may contain mistakes; the official description above is the record.
