{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-auth-webauthn.","exploited":"There is no known exploitation of CVE-2026-62263 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-auth-webauthn to 16.1.2 or later.","what":"CVE-2026-62263 is a critical unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-62263 and fix it if it is affected.\n\nWhat it is: CVE-2026-62263 is a critical unsafe deserialization vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-62263 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-auth-webauthn (Maven): affected all versions; fixed in 16.1.2\n- org.openidentityplatform.openam:openam-auth-webauthn (Maven): affected all versions; fixed in 16.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62263/ (Markdown: https://insights.sbomify.com/CVE-2026-62263/index.md)","id":"CVE-2026-62263","markdown":"https://insights.sbomify.com/CVE-2026-62263/index.md","name":"CVE-2026-62263","record":{"aliases":["GHSA-gf8h-gq53-288j","UBUNTU-CVE-2026-62263"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"Pre-authentication attackers can achieve remote code execution in OpenAM by bypassing deserialization filters in WebAuthn authentication.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.2, WebAuthnAuthentication.deserialize applies an ObjectInputFilter that allows every serialized object at depth greater than 1 and therefore constrains only an AuthenticatorImpl root object. A pre-authentication attacker can supply a userHandle whose serialized graph has a valid AuthenticatorImpl root and a nested gadget class, causing readObject or readResolve execution before the cast and assertion verification when a usable gadget is on the classpath. This bypasses the incomplete remediation for the earlier WebAuthn deserialization vulnerability. This issue is fixed in version 16.1.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM: WebAuthn Java deserialization RCE via ObjectInputFilter depth\u003e1 bypass","id":"CVE-2026-62263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Path traversal in lubelog","id":"CVE-2026-62278"},"packages":[{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-auth-webauthn","purl":null,"source":"GHSA-gf8h-gq53-288j"},{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-auth-webauthn","purl":"pkg:maven/org.openidentityplatform.openam/openam-auth-webauthn","source":"GHSA-gf8h-gq53-288j"}],"prev":{"headline":"Piwigo: Unauthenticated SQL injection in `pwg.images.filteredSearch.create`","id":"CVE-2026-62262"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Pre-authentication attackers can achieve remote code execution in OpenAM by bypassing deserialization filters in WebAuthn authentication.","url":"https://insights.sbomify.com/CVE-2026-62263/"}