CVE-2026-62280 OpenAM Reflected XSS in the OAuth2/OIDC `wap` consent page

Medium 6.1 Published Updated

Attackers can execute JavaScript in OpenAM via a crafted OAuth2 consent link, stealing sessions and cookies from authenticated users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-62280?

CVE-2026-62280 is a medium-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Open Access Management (OpenAM) is an access management solution. From 13.0.0 until 16.1.2, the OAuth2 authorize endpoint's display=wap consent page reflects request-derived values through ConsentRequiredResource and wap/authorize.ftl without HTML escaping. An attacker can induce a user with an active OpenAM session to follow a crafted authorization link and execute JavaScript in the OpenAM origin, enabling session or cookie theft, CSRF-token disclosure, and actions with the victim's privileges. At least one registered OAuth2 client is required, but the attacker does not need to control that client. This issue is fixed in version 16.1.2.

Weakness: CWE-79

Which versions are affected by CVE-2026-62280?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.

PackageAffectedFixed in
org.openidentityplatform.openam:openam-oauth2 MavenFrom 13.0.016.1.2
org.openidentityplatform.openam:openam-oauth2 MavenFrom 13.0.016.1.2

How do I fix CVE-2026-62280?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-62280 being exploited?

There is no known exploitation of CVE-2026-62280 in the wild and no public exploit code.

Sources

Also known as GHSA-vqxv-6xrh-49cp, UBUNTU-CVE-2026-62280.

Is CVE-2026-62280 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free