{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.","exploited":"There is no known exploitation of CVE-2026-62280 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.2 or later.","what":"CVE-2026-62280 is a medium-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-62280 and fix it if it is affected.\n\nWhat it is: CVE-2026-62280 is a medium-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-62280 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.2\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62280/ (Markdown: https://insights.sbomify.com/CVE-2026-62280/index.md)","id":"CVE-2026-62280","markdown":"https://insights.sbomify.com/CVE-2026-62280/index.md","name":"CVE-2026-62280","record":{"aliases":["GHSA-vqxv-6xrh-49cp","UBUNTU-CVE-2026-62280"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"Attackers can execute JavaScript in OpenAM via a crafted OAuth2 consent link, stealing sessions and cookies from authenticated users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Open Access Management (OpenAM) is an access management solution. From 13.0.0 until 16.1.2, the OAuth2 authorize endpoint's display=wap consent page reflects request-derived values through ConsentRequiredResource and wap/authorize.ftl without HTML escaping. An attacker can induce a user with an active OpenAM session to follow a crafted authorization link and execute JavaScript in the OpenAM origin, enabling session or cookie theft, CSRF-token disclosure, and actions with the victim's privileges. At least one registered OAuth2 client is required, but the attacker does not need to control that client. This issue is fixed in version 16.1.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM Reflected XSS in the OAuth2/OIDC `wap` consent page","id":"CVE-2026-62280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"OpenCVE: Server-Side Request Forgery (SSRF) in notifications","id":"CVE-2026-62282"},"packages":[{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["13.0.0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":null,"source":"GHSA-vqxv-6xrh-49cp"},{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["13.0.0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":"pkg:maven/org.openidentityplatform.openam/openam-oauth2","source":"GHSA-vqxv-6xrh-49cp"}],"prev":{"headline":"Missing authorization in lubelog","id":"CVE-2026-62279"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["OpenIdentityPlatform"]},"summary":"Attackers can execute JavaScript in OpenAM via a crafted OAuth2 consent link, stealing sessions and cookies from authenticated users.","url":"https://insights.sbomify.com/CVE-2026-62280/"}