# CVE-2026-62280: OpenAM Reflected XSS in the OAuth2/OIDC `wap` consent page

> Attackers can execute JavaScript in OpenAM via a crafted OAuth2 consent link, stealing sessions and cookies from authenticated users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** GHSA-vqxv-6xrh-49cp, UBUNTU-CVE-2026-62280

## What is CVE-2026-62280?

CVE-2026-62280 is a medium-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open Access Management (OpenAM) is an access management solution. From 13.0.0 until 16.1.2, the OAuth2 authorize endpoint's display=wap consent page reflects request-derived values through ConsentRequiredResource and wap/authorize.ftl without HTML escaping. An attacker can induce a user with an active OpenAM session to follow a crafted authorization link and execute JavaScript in the OpenAM origin, enabling session or cookie theft, CSRF-token disclosure, and actions with the victim's privileges. At least one registered OAuth2 client is required, but the attacker does not need to control that client. This issue is fixed in version 16.1.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-62280?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | From 13.0.0 | 16.1.2 |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | From 13.0.0 | 16.1.2 |

## How do I fix CVE-2026-62280?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.2 or later.

## Is CVE-2026-62280 being exploited?

There is no known exploitation of CVE-2026-62280 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62280 and fix it if it is affected.

What it is: CVE-2026-62280 is a medium-severity cross-site scripting vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-62280 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.2
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected from 13.0.0; fixed in 16.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62280/ (Markdown: https://insights.sbomify.com/CVE-2026-62280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62280
- OSV: https://osv.dev/vulnerability/CVE-2026-62280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62280/
Summaries are generated and may contain mistakes; the official description above is the record.
