{"answers":{"affected":"3 open source packages ship an affected version, including opencve.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62282 exists.","fix":"Upgrade opencve to 3.0.0 or later.","what":"CVE-2026-62282 is a medium-severity server-side request forgery vulnerability in opencve, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-62282 and fix it if it is affected.\n\nWhat it is: CVE-2026-62282 is a medium-severity server-side request forgery vulnerability in opencve, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62282 exists.\n\nAffected packages and fixed versions:\n- opencve (PyPI): affected all versions; fixed in 3.0.0\n- opencve (PyPI): affected all versions; fixed in 3.0.0\n- opencve (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62282/ (Markdown: https://insights.sbomify.com/CVE-2026-62282/index.md)","id":"CVE-2026-62282","markdown":"https://insights.sbomify.com/CVE-2026-62282/index.md","name":"CVE-2026-62282","record":{"aliases":["GHSA-ch3g-4xvr-674q","PYSEC-2026-4130"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCVE vulnerability platform","requires_auth":"low_privilege","summary":"Authenticated users can exploit insufficient URL validation in notification settings to access internal network resources and cloud metadata services.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"OpenCVE is a vulnerability intelligence platform. Prior to 3.0.0, OpenCVE notification testing for Webhook and Slack integrations does not sufficiently validate user-supplied HTTP or HTTPS destinations. An authenticated user with permission to configure notification channels can trigger requests to hosts reachable from the OpenCVE server, including internal network resources, localhost interfaces, link-local addresses, and cloud metadata services, and retrieve information from reachable HTTP services. This issue is fixed in version 3.0.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"OpenCVE: Server-Side Request Forgery (SSRF) in notifications","id":"CVE-2026-62282","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":5,"next":{"headline":"Nezha Monitoring: Cross-tenant terminal/file-manager session hijack via WebSocket stream UUID without ownership check","id":"CVE-2026-62283"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"opencve","purl":null,"source":"GHSA-ch3g-4xvr-674q"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"opencve","purl":"pkg:pypi/opencve","source":"GHSA-ch3g-4xvr-674q"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"opencve","purl":"pkg:pypi/opencve","source":"PYSEC-2026-4130"}],"prev":{"headline":"OpenAM Reflected XSS in the OAuth2/OIDC `wap` consent page","id":"CVE-2026-62280"},"products":["opencve"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["opencve"]},"summary":"Authenticated users can exploit insufficient URL validation in notification settings to access internal network resources and cloud metadata services.","url":"https://insights.sbomify.com/CVE-2026-62282/"}