# CVE-2026-62282: OpenCVE: Server-Side Request Forgery (SSRF) in notifications

> Authenticated users can exploit insufficient URL validation in notification settings to access internal network resources and cloud metadata services.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-ch3g-4xvr-674q, PYSEC-2026-4130

## What is CVE-2026-62282?

CVE-2026-62282 is a medium-severity server-side request forgery vulnerability in opencve, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenCVE is a vulnerability intelligence platform. Prior to 3.0.0, OpenCVE notification testing for Webhook and Slack integrations does not sufficiently validate user-supplied HTTP or HTTPS destinations. An authenticated user with permission to configure notification channels can trigger requests to hosts reachable from the OpenCVE server, including internal network resources, localhost interfaces, link-local addresses, and cloud metadata services, and retrieve information from reachable HTTP services. This issue is fixed in version 3.0.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-62282?

3 open source packages ship an affected version, including opencve.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencve` | PyPI | All versions | 3.0.0 |
| `opencve` | PyPI | All versions | 3.0.0 |
| `opencve` | PyPI | All versions | 3.0.0 |

## How do I fix CVE-2026-62282?

Upgrade opencve to 3.0.0 or later.

## Is CVE-2026-62282 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62282 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62282 and fix it if it is affected.

What it is: CVE-2026-62282 is a medium-severity server-side request forgery vulnerability in opencve, published on 18 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62282 exists.

Affected packages and fixed versions:
- opencve (PyPI): affected all versions; fixed in 3.0.0
- opencve (PyPI): affected all versions; fixed in 3.0.0
- opencve (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62282/ (Markdown: https://insights.sbomify.com/CVE-2026-62282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62282
- OSV: https://osv.dev/vulnerability/CVE-2026-62282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62282/
Summaries are generated and may contain mistakes; the official description above is the record.
