{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62295 exists.","fix":"No fix has been published for CVE-2026-62295 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-62295 is a high-severity denial of service vulnerability in hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-62295 and fix it if it is affected.\n\nWhat it is: CVE-2026-62295 is a high-severity denial of service vulnerability in hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62295 exists.\n\nAffected product: hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62295/ (Markdown: https://insights.sbomify.com/CVE-2026-62295/index.md)","id":"CVE-2026-62295","markdown":"https://insights.sbomify.com/CVE-2026-62295/index.md","name":"CVE-2026-62295","record":{"aliases":["GHSA-2cq7-hg49-56gc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java FHIR library","requires_auth":"none","summary":"Attackers can crash HAPI FHIR services by submitting deeply nested JSON, causing stack overflow and denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, the JSON utility parser in org.hl7.fhir.utilities.json.parser.JsonParser enforces no maximum nesting depth for arrays or objects. As a result, a small but deeply nested, syntactically valid FHIR JSON document can trigger unbounded readArray() or readObject() recursion, raising a StackOverflowError before structural validation runs. An attacker who can submit JSON resources for validation can thus crash the request thread, and services that do not isolate StackOverflowError safely may experience worker loss or process instability — a denial-of-service condition. This issue is fixed in version 6.9.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"HAPI FHIR: JSON utility parser unbounded recursion causes StackOverflow denial of service","id":"CVE-2026-62295","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"HAPI FHIR: XHTML narrative parser unbounded recursion causes StackOverflow denial of service","id":"CVE-2026-62296"},"packages":[],"prev":{"headline":"Flameshot: OCTOU symlink attack via predictable /tmp path in Flameshot \"Open With\"","id":"CVE-2026-62294"},"products":["ca.uhn.hapi.fhir:org.hl7.fhir.r5","ca.uhn.hapi.fhir:org.hl7.fhir.utilities","ca.uhn.hapi.fhir:org.hl7.fhir.validation","ca.uhn.hapi.fhir:org.hl7.fhir.validation.cli","org.hl7.fhir.core"],"published":"2026-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-13","vendors":["hapifhir"]},"summary":"Attackers can crash HAPI FHIR services by submitting deeply nested JSON, causing stack overflow and denial of service.","url":"https://insights.sbomify.com/CVE-2026-62295/"}