# CVE-2026-62295: HAPI FHIR: JSON utility parser unbounded recursion causes StackOverflow denial of service

> Attackers can crash HAPI FHIR services by submitting deeply nested JSON, causing stack overflow and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-2cq7-hg49-56gc

## What is CVE-2026-62295?

CVE-2026-62295 is a high-severity denial of service vulnerability in hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAPI FHIR is a complete implementation of the HL7 FHIR standard for healthcare interoperability in Java. Prior to 6.9.11, the JSON utility parser in org.hl7.fhir.utilities.json.parser.JsonParser enforces no maximum nesting depth for arrays or objects. As a result, a small but deeply nested, syntactically valid FHIR JSON document can trigger unbounded readArray() or readObject() recursion, raising a StackOverflowError before structural validation runs. An attacker who can submit JSON resources for validation can thus crash the request thread, and services that do not isolate StackOverflowError safely may experience worker loss or process instability — a denial-of-service condition. This issue is fixed in version 6.9.11.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-62295?


## How do I fix CVE-2026-62295?

No fix has been published for CVE-2026-62295 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62295 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62295 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62295 and fix it if it is affected.

What it is: CVE-2026-62295 is a high-severity denial of service vulnerability in hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5, published on 7 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62295 exists.

Affected product: hapifhir ca.uhn.hapi.fhir:org.hl7.fhir.r5. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62295/ (Markdown: https://insights.sbomify.com/CVE-2026-62295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62295
- OSV: https://osv.dev/vulnerability/CVE-2026-62295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62295/
Summaries are generated and may contain mistakes; the official description above is the record.
