# CVE-2026-62312: 9Router: Authenticated RCE via Unvalidated MCP Plugin Arguments

> Authenticated attackers can execute arbitrary code on the host by bypassing localhost restrictions and injecting commands via unvalidated MCP plugin arguments.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** GHSA-63p9-g54h-prrp

## What is CVE-2026-62312?

CVE-2026-62312 is a high-severity command injection vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

9Router is an AI router & token saver. Prior to 0.5.2, 9Router allows a remote authenticated attacker to achieve arbitrary code execution on the host operating system by combining a Host header bypass of localhost-only routes with unvalidated MCP plugin args passed to child_process.spawn(), allowing malicious custom plugins to execute commands through /api/mcp//sse. This issue is fixed in version 0.5.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-62312?


## How do I fix CVE-2026-62312?

No fix has been published for CVE-2026-62312 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62312 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62312 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62312 and fix it if it is affected.

What it is: CVE-2026-62312 is a high-severity command injection vulnerability in decolua 9router, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62312 exists.

Affected product: decolua 9router. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62312/ (Markdown: https://insights.sbomify.com/CVE-2026-62312/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62312
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62312
- OSV: https://osv.dev/vulnerability/CVE-2026-62312

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62312/
Summaries are generated and may contain mistakes; the official description above is the record.
