# CVE-2026-62317: Logto: ReDoS via unescaped user input in email subaddressing regex (blockSubaddressing)

> Attackers can cause denial of service in Logto authentication services by triggering catastrophic backtracking in email validation regex when subaddressing blocking is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-qp7j-c3q2-g739

## What is CVE-2026-62317?

CVE-2026-62317 is a high-severity denial of service vulnerability in logto-io logto, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Logto is the modern, open-source auth infrastructure for SaaS and AI apps. Prior to 1.41.0, Logto's email subaddressing blocklist in packages/core/src/libraries/sign-in-experience/email-blocklist-policy.ts used the attacker-controlled domain from email input to construct subaddressingRegex when blockSubaddressing was enabled. The permissive emailRegEx accepted multiple at signs and regular expression metacharacters, and POST /api/experience/verification/verification-code could therefore cause catastrophic backtracking in subaddressingRegex.test(email). The resulting event-loop stall could make authentication, token issuance, SSO, and the administrative console unavailable. This issue is fixed in version 1.41.0.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-62317?


## How do I fix CVE-2026-62317?

No fix has been published for CVE-2026-62317 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62317 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62317 and fix it if it is affected.

What it is: CVE-2026-62317 is a high-severity denial of service vulnerability in logto-io logto, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62317 exists.

Affected product: logto-io logto. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62317/ (Markdown: https://insights.sbomify.com/CVE-2026-62317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62317
- OSV: https://osv.dev/vulnerability/CVE-2026-62317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62317/
Summaries are generated and may contain mistakes; the official description above is the record.
