# CVE-2026-62322: Python Social Auth: Login CSRF in LINE backend (LineOAuth2) — missing OAuth state validation (incomplete fix of 5.0.0 campaign)

> Attackers can force victims into attacker-controlled accounts or link attacker identities to victim accounts via missing OAuth state validation in the LINE backend.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-62322, GHSA-526j-582w-7fm9, UBUNTU-CVE-2026-62322

## What is CVE-2026-62322?

CVE-2026-62322 is a medium-severity vulnerability in python-social-auth social-core, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Python Social Auth is a social authentication/registration mechanism. Prior to 5.0.2, the LINE backend exchanges an authorization code without validating the returned OAuth state. An attacker can begin authorization for an attacker-controlled LINE account and induce a victim to visit the resulting callback URL, causing the application to log the victim into the attacker's account. When account linking is enabled, the same missing validation can link the attacker's LINE identity to the victim's existing account and create a persistent unauthorized login path. Only applications with the LINE backend enabled are affected. This issue is fixed in version 5.0.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-62322?

2 open source packages ship an affected version, including social-auth-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `social-auth-core` | PyPI | All versions | 5.0.2 |
| `social-auth-core` | PyPI | All versions | 5.0.2 |

## How do I fix CVE-2026-62322?

Upgrade social-auth-core to 5.0.2 or later.

## Is CVE-2026-62322 being exploited?

There is no known exploitation of CVE-2026-62322 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62322 and fix it if it is affected.

What it is: CVE-2026-62322 is a medium-severity vulnerability in python-social-auth social-core, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-62322 in the wild and no public exploit code.

Affected packages and fixed versions:
- social-auth-core (PyPI): affected all versions; fixed in 5.0.2
- social-auth-core (PyPI): affected all versions; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62322/ (Markdown: https://insights.sbomify.com/CVE-2026-62322/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62322
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62322
- OSV: https://osv.dev/vulnerability/CVE-2026-62322

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62322/
Summaries are generated and may contain mistakes; the official description above is the record.
