# CVE-2026-62323: Cloudreve: Unauthorized file write via WOPI view sessions whose access token secret is ignored

> Attackers can forge WOPI access tokens to write files via view sessions, allowing unauthorized data modification in Cloudreve.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-c3jm-gv5r-9wcp, GO-2026-6104

## What is CVE-2026-62323?

CVE-2026-62323 is a medium-severity missing authorization vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cloudreve is a self-hosted file management and sharing system. Prior to 4.17.0, ViewerSessionValidation uses only the session-id prefix of a WOPI access token and does not enforce the requested viewer action, allowing a malicious or compromised WOPI viewer with a view session to forge the token suffix and invoke WOPI write routes for the underlying file. This issue is fixed in version 4.17.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62323?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022433-f3347130ac48 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022433-f3347130ac48 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022433-f3347130ac48 |

## How do I fix CVE-2026-62323?

Upgrade to a fixed version.

## Is CVE-2026-62323 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62323 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62323 and fix it if it is affected.

What it is: CVE-2026-62323 is a medium-severity missing authorization vulnerability in cloudreve, published on 31 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62323 exists.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022433-f3347130ac48
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022433-f3347130ac48
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022433-f3347130ac48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62323/ (Markdown: https://insights.sbomify.com/CVE-2026-62323/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62323
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62323
- OSV: https://osv.dev/vulnerability/CVE-2026-62323

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62323/
Summaries are generated and may contain mistakes; the official description above is the record.
