# CVE-2026-62354: Apache NiFi: Incorrect Authorization for Parameter Context Validation Requests

> Users with read access can modify parameter configurations by bypassing authorization checks, requiring an upgrade to enforce write permissions.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/S:P/AU:Y/R:I/V:C/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2026
- **Updated:** 5 Aug 2026
- **Also known as:** BIT-nifi-2026-62354, GHSA-m6hg-5m93-2wrv, MINI-h68g-2frf-w3gv, MINI-wjc7-h5wg-g3vh

## What is CVE-2026-62354?

CVE-2026-62354 is a high-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization handling for Parameter Context validation requests in Apache NiFi 1.10.0 through 2.10.0 allows clients with read access to submit proposed Parameter values. The proposed values override current configuration, enabling users with read access to invoke predefined component validation methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying Parameter Context configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.11.0 is the recommended mitigation, requiring write access to submit Parameter Context validation requests.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62354?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 1.10.0 | 2.11.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-62354?

Upgrade nifi to 2.11.0 or later.

## Is CVE-2026-62354 being exploited?

There is no known exploitation of CVE-2026-62354 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62354 and fix it if it is affected.

What it is: CVE-2026-62354 is a high-severity missing authorization vulnerability in Apache Nifi, published on 3 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62354 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 1.10.0; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62354/ (Markdown: https://insights.sbomify.com/CVE-2026-62354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62354
- OSV: https://osv.dev/vulnerability/CVE-2026-62354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62354/
Summaries are generated and may contain mistakes; the official description above is the record.
