{"answers":{"affected":"3 open source packages ship an affected version, including wlc.","exploited":"There is no known exploitation of CVE-2026-62364 in the wild and no public exploit code.","fix":"Upgrade wlc to 2.0.1 or later.","what":"CVE-2026-62364 is a low-severity vulnerability in WeblateOrg wlc, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-62364 and fix it if it is affected.\n\nWhat it is: CVE-2026-62364 is a low-severity vulnerability in WeblateOrg wlc, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-62364 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wlc (PyPI): affected all versions; fixed in 2.0.1\n- wlc (PyPI): affected all versions; fixed in 2.0.1\n- wlc (PyPI): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62364/ (Markdown: https://insights.sbomify.com/CVE-2026-62364/index.md)","id":"CVE-2026-62364","markdown":"https://insights.sbomify.com/CVE-2026-62364/index.md","name":"CVE-2026-62364","record":{"aliases":["DEBIAN-CVE-2026-62364","GHSA-3mqq-hv9c-85hc","PYSEC-2026-4180","UBUNTU-CVE-2026-62364"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Weblate CLI client","requires_auth":"high_privilege","summary":"An attacker can steal API tokens by placing malicious configuration files in a directory where the Weblate CLI is executed.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-349","name":"Acceptance of Extraneous Untrusted Data With Trusted Data"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"wlc is a Weblate command-line client using Weblate's REST API. Prior to 2.0.1, automatically discovered configuration from .weblate, .weblate.ini, or weblate.ini can select the API URL while an unscoped API token is supplied through WLC_KEY or --key without a matching WLC_URL or --url. When wlc runs in an untrusted repository, pull request checkout, or directory with untrusted ancestor configuration, it can send the token to an attacker-controlled project-configured URL. URL-scoped keys in [keys] are not affected. This issue is fixed in version 2.0.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"wlc may disclose API tokens to project-configured URLs","id":"CVE-2026-62364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Vikunja: OIDC email-fallback account linking ignores email_verified, enabling local-account takeover","id":"CVE-2026-62367"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":null,"source":"GHSA-3mqq-hv9c-85hc"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"GHSA-3mqq-hv9c-85hc"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"wlc","purl":"pkg:pypi/wlc","source":"PYSEC-2026-4180"}],"prev":{"headline":"ImageMagick: Heap Buffer Over-Write in fx operation","id":"CVE-2026-62363"},"products":["wlc"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["WeblateOrg"]},"summary":"An attacker can steal API tokens by placing malicious configuration files in a directory where the Weblate CLI is executed.","url":"https://insights.sbomify.com/CVE-2026-62364/"}