{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-core.","exploited":"There is no known exploitation of CVE-2026-62379 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-core to 16.1.2 or later.","what":"CVE-2026-62379 is a critical code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-62379 and fix it if it is affected.\n\nWhat it is: CVE-2026-62379 is a critical code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-62379 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.2\n- org.openidentityplatform.openam:openam-core (Maven): affected all versions; fixed in 16.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-62379/ (Markdown: https://insights.sbomify.com/CVE-2026-62379/index.md)","id":"CVE-2026-62379","markdown":"https://insights.sbomify.com/CVE-2026-62379/index.md","name":"CVE-2026-62379","record":{"aliases":["GHSA-wg5r-wc3x-39vc","UBUNTU-CVE-2026-62379"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code on OpenAM servers by exploiting unsafe class loading in the authentication service endpoint.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.2, the pre-authentication /authservice PLL endpoint accepts a CustomCallback XML element whose className value selects an arbitrary Java class for AuthXMLUtils to load and instantiate without verifying that it implements DSAMECallbackInterface. Default configurations expose the endpoint without authentication, allowing attacker-controlled class initialization and unsafe deserialization of a serialized Subject value to execute code in the server process. Enabling sunRemoteAuthSecurityEnabled does not prevent the vulnerable parsing and instantiation because its check occurs later. This issue is fixed in version 16.1.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM: Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback","id":"CVE-2026-62379","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Netty before 4.2.16.Final SOCKS Proxy Null Byte Injection","id":"CVE-2026-62380"},"packages":[{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":null,"source":"GHSA-wg5r-wc3x-39vc"},{"ecosystem":"Maven","fixed":["16.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-core","purl":"pkg:maven/org.openidentityplatform.openam/openam-core","source":"GHSA-wg5r-wc3x-39vc"}],"prev":{"headline":"RustFS Console: Critical Stored XSS in Preview Modal leading to Administrative Account Takeover","id":"CVE-2026-62378"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Unauthenticated attackers can execute arbitrary code on OpenAM servers by exploiting unsafe class loading in the authentication service endpoint.","url":"https://insights.sbomify.com/CVE-2026-62379/"}