# CVE-2026-62382: PasswordPusher before v2.9.6 Authentication Bypass via Null Comparison

> Attackers can delete anonymous password pushes without authorization due to a null comparison flaw in ownership checks.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-h7j9-p76m-fhvx, GHSA-jf2m-hpj9-4qx2

## What is CVE-2026-62382?

CVE-2026-62382 is a medium-severity authentication bypass vulnerability in pglombardo PasswordPusher, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PasswordPusher versions v1.45.11 through v2.9.5 contain an improper authorization vulnerability in the push deletion logic. The ownership check compares @push.user against current_user; for an anonymously created push both values are nil, and Ruby evaluates nil == nil as true, so the check passes and the deletable_by_viewer restriction is never enforced. An attacker who knows only the secret URL can permanently delete an anonymous push even when the creator disabled viewer deletion and even without the passphrase. Only deployments that allow anonymous pushes (the default) are affected. The issue is fixed in v2.9.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-62382?


## How do I fix CVE-2026-62382?

No fix has been published for CVE-2026-62382 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62382 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62382 exists.

Public exploit code:

- PasswordPusher v1.45.11-v2.9.5 - Unauthenticated Anonymous Push Deletion via Ownership Bypass (nuclei): http/cves/2026/CVE-2026-62382.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62382 and fix it if it is affected.

What it is: CVE-2026-62382 is a medium-severity authentication bypass vulnerability in pglombardo PasswordPusher, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62382 exists.

Affected product: pglombardo PasswordPusher. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62382/ (Markdown: https://insights.sbomify.com/CVE-2026-62382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62382
- OSV: https://osv.dev/vulnerability/CVE-2026-62382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62382/
Summaries are generated and may contain mistakes; the official description above is the record.
