CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API

Critical 9.8 Published Updated

Attackers can inject SQL commands via the catalog cache refresh API, potentially reading or modifying data in Apache Kylin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-62390?

CVE-2026-62390 is a critical SQL injection vulnerability in Apache Kylin, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL.

This issue affects Apache Kylin: from 4 through 5.0.3.

Users are recommended to upgrade to version 5.0.4, which fixes the issue.

Weakness: CWE-89

Which versions are affected by CVE-2026-62390?

It affects 1 product.

Products include Apache Kylin.

How do I fix CVE-2026-62390?

No fix has been published for CVE-2026-62390 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-62390 being exploited?

There is no known exploitation of CVE-2026-62390 in the wild and no public exploit code.

Sources

Also known as GHSA-92vx-x7gx-68cf.

Is CVE-2026-62390 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free