# CVE-2026-62390: Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API

> Attackers can inject SQL commands via the catalog cache refresh API, potentially reading or modifying data in Apache Kylin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-92vx-x7gx-68cf

## What is CVE-2026-62390?

CVE-2026-62390 is a critical SQL injection vulnerability in Apache Kylin, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL.

This issue affects Apache Kylin: from 4 through 5.0.3.

Users are recommended to upgrade to version 5.0.4, which fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-62390?

It affects 1 product.


Products: Apache Kylin.

## How do I fix CVE-2026-62390?

No fix has been published for CVE-2026-62390 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62390 being exploited?

There is no known exploitation of CVE-2026-62390 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)
- [CVE-2021-45456](https://insights.sbomify.com/CVE-2021-45456/): Command injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62390 and fix it if it is affected.

What it is: CVE-2026-62390 is a critical SQL injection vulnerability in Apache Kylin, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62390 in the wild and no public exploit code.

Affected product: Apache Kylin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62390/ (Markdown: https://insights.sbomify.com/CVE-2026-62390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62390
- OSV: https://osv.dev/vulnerability/CVE-2026-62390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62390/
Summaries are generated and may contain mistakes; the official description above is the record.
