CVE-2026-62392 Apache Kylin: OS Command Injection via Async Query API

High 8.8 Published Updated

Attackers can execute arbitrary OS commands via the Async Query API in Apache Kylin, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-62392?

CVE-2026-62392 is a high-severity command injection vulnerability in Apache Kylin, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Kylin. A backend API may bring job config parameters to OS command line.

This issue affects Apache Kylin: from 4 through 5.0.3.

Users are recommended to upgrade to version 5.0.4, which fixes the issue.

Weakness: CWE-78

Which versions are affected by CVE-2026-62392?

It affects 1 product.

Products include Apache Kylin.

How do I fix CVE-2026-62392?

No fix has been published for CVE-2026-62392 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-62392 being exploited?

There is no known exploitation of CVE-2026-62392 in the wild and no public exploit code.

Sources

Also known as GHSA-vv75-pcv7-p758.

Is CVE-2026-62392 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free