CVE-2026-62440 Apache CloudStack: Improper access control in Kubernetes Service (CKS) cluster manipulation

Critical 9.1 Published Updated

Attackers can manipulate Kubernetes clusters across tenants by adding or removing nodes due to improper access control in the CKS plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-62440?

CVE-2026-62440 is a critical missing authorization vulnerability in Apache Cloudstack, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes.

This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0.

Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.

Weakness: CWE-284

Which versions are affected by CVE-2026-62440?

It affects 1 product.

Products include Apache Cloudstack.

How do I fix CVE-2026-62440?

No fix has been published for CVE-2026-62440 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-62440 being exploited?

There is no known exploitation of CVE-2026-62440 in the wild and no public exploit code.

All Apache Cloudstack vulnerabilities

Sources

Also known as GHSA-2vq4-5w2v-frrg.

Is CVE-2026-62440 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free