CVE-2026-6267 Insertion of Sensitive Information Into Sent Data in GitLab
An authenticated Developer can access unauthorized information due to insufficient access controls in internal request handling.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6267?
CVE-2026-6267 is a high-severity vulnerability in Gitlab Gitlab, published on 29 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 10.1.0 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 that under certain conditions could have allowed an authenticated user with Developer role to access unauthorized information due to insufficient access controls on internal request handling.
Weakness: CWE-201
Which versions are affected by CVE-2026-6267?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 10.1.0 | 19.0.5, 19.1.3, 19.2.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2026-6267?
Upgrade gitlab to a fixed version for your release line: 19.0.5, 19.1.3 or 19.2.1.
Is CVE-2026-6267 being exploited?
There is no known exploitation of CVE-2026-6267 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2026-6267, GHSA-6fhj-cgmm-xfx6, MINI-75g8-4w6c-fhfx, MINI-c993-hm8h-g8cw.