# CVE-2026-62670: Missing authorization in grav-plugin-flex-objects

> Authenticated users with API access can perform unauthorized CRUD operations on directories lacking explicit permission configurations in the Grav Flex Objects plugin.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026

## What is CVE-2026-62670?

CVE-2026-62670 is a medium-severity missing authorization vulnerability in getgrav grav-plugin-flex-objects, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav Flex Objects Plugin allows you to build custom collections of objects. Prior to 1.4.3, the Grav Flex Objects Admin Next API requireFlexPermission() method in classes/Api/FlexApiController.php returns without denying access when a directory blueprint omits config.admin.permissions. An authenticated account with only api.access can use the index, show, create, update, delete, export, and media handlers for a permission-less directory even though the core admin.flex-object. authorization fallback would deny the same actions. This issue is fixed in version 1.4.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-62670?


## How do I fix CVE-2026-62670?

No fix has been published for CVE-2026-62670 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-62670 being exploited?

There is no known exploitation of CVE-2026-62670 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62670 and fix it if it is affected.

What it is: CVE-2026-62670 is a medium-severity missing authorization vulnerability in getgrav grav-plugin-flex-objects, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-62670 in the wild and no public exploit code.

Affected product: getgrav grav-plugin-flex-objects. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62670/ (Markdown: https://insights.sbomify.com/CVE-2026-62670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62670
- OSV: https://osv.dev/vulnerability/CVE-2026-62670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62670/
Summaries are generated and may contain mistakes; the official description above is the record.
