# CVE-2026-62672: Grav: Authenticated ReDoS via regex_replace in Twig Sandbox

> Authenticated editors can cause denial of service via catastrophic regex backtracking in Grav CMS when Twig content processing is enabled.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026

## What is CVE-2026-62672?

CVE-2026-62672 is a medium-severity denial of service vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 2.0.4, Grav allowlists the regex_replace filter and function in system/config/security.yaml, and GravExtension::regexReplace() passes an editor-controlled pattern directly to preg_replace(). When security.twig_content.process_enabled is enabled, an authenticated page editor can publish a catastrophically backtracking pattern that consumes PHP worker CPU and denies service to site visitors. This issue is fixed in version 2.0.4.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-62672?


## How do I fix CVE-2026-62672?

Upgrade to a fixed version.

## Is CVE-2026-62672 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62672 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-62672 and fix it if it is affected.

What it is: CVE-2026-62672 is a medium-severity denial of service vulnerability in getgrav grav, published on 19 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-62672 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-62672/ (Markdown: https://insights.sbomify.com/CVE-2026-62672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-62672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-62672
- OSV: https://osv.dev/vulnerability/CVE-2026-62672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-62672/
Summaries are generated and may contain mistakes; the official description above is the record.
